#88 ✓resolved
Peter Johnson

Runtime error when trying to assemble

Reported by Peter Johnson | June 25th, 2011 @ 07:49 PM

Originally posted on Trac by Echo
Original Trac Ticket

  Description

  @@@

C:\Documents and Settings\Ejer\Skrivebord\YASM>yasm -f bin iso9660boot.asm -o is
oboot.bin
INTERNAL ERROR at ......\modules\arch\x86\x86bc.c, line 927: invalid Mod/RM in
x86 tobytes_insn

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.


That is what happens when i try to assemble my bootsector. It happened when I moved a string db into my .text section.. email me and I'll supply assembly code.

  
h3. Trac Attachments

h3. Trac Comments
comment:1
    
                  
                  Changed 5 years ago by peter@tortall.net

Symptom of combining old optimizer and invalid input (negative TIMES value), so no longer appears with new optimizer (more recent snapshot versions).

  comment:1

              Changed 5 years ago by peter@tortall.net

  Status
    changed from new to closed

  Resolution
    set to fixed

Symptom of combining old optimizer and invalid input (negative TIMES value), so no longer appears with new optimizer (more recent snapshot versions).

  Status
    changed from new to closed

  Resolution
    set to fixed

No comments found

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

The Yasm Modular Assembler Project

Shared Ticket Bins

People watching this ticket

Tags

Pages