#95 ✓resolved
Peter Johnson

Segmentation fault with expressions like (label>>8)

Reported by Peter Johnson | June 25th, 2011 @ 07:50 PM

Originally posted on Trac by wingedtachikoma@gmail.com
Original Trac Ticket

  Description

Segmentation fault when assembling the following code:

x: MOV AL, (x>>8)

Trac Attachments

h3. Trac Comments
comment:1

              Changed 4 years ago by peter


(In [1744]) Fix >8) (closed: fixed)" class="closed ticket">#97: Support right-shifted symbols in binary output (the root cause).

Also fix the symptom by checking for non-NULL value->rel.

      comment:1

                  Changed 4 years ago by peter

      Status
        changed from new to closed
    
      Resolution
        set to fixed

(In [1744]) Fix >8) (closed: fixed)" class="closed ticket">#97: Support right-shifted symbols in binary output (the root cause).

Also fix the symptom by checking for non-NULL value->rel.

      Status
        changed from new to closed
    
      Resolution
        set to fixed

No comments found

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

The Yasm Modular Assembler Project

Shared Ticket Bins

People watching this ticket

Tags

Pages